UPGRADING TO EXTENDSIM 10
Table of Contents

Welcome to ExtendSim 10 and Thank You for Upgrading! ................................................................. 1
Requirements ........................................................................................................................................... 1
Overview ............................................................................................................................................... 2
Before Upgrading to ExtendSim 10 ........................................................................................................ 3
Installing, Launching, and Activating ES10 .......................................................................................... 4
After Launching ES10 ............................................................................................................................ 6
Verifying Models: Automating the Process ........................................................................................... 7
New Features to Note When Using ES10 ............................................................................................... 8
Maintenance and Support ....................................................................................................................... 10
Legacy libraries warning ....................................................................................................................... 10
Learning How to Use ExtendSim 10 ..................................................................................................... 11
If You Have Created Custom Blocks .................................................................................................. 12
Other Things to be Aware of for Custom Blocks ................................................................................ 12
Welcome to ExtendSim 10 and Thank You for Upgrading!

It’s not just an upgrade!

ExtendSim 10 (ES10) is a complete rewrite of ExtendSim using an industry standard IDE (integrated development environment) and a cutting-edge cross-platform application framework.

This major release has a whole new look and feel plus it is packed with enhancements designed to simplify and accelerate your modeling experience. Its modern interface incorporates the newest ideas and most up-to-date features. Its 64-bit, multi-threaded simulation engine can handle the largest modeling tasks.

Even if you are accustomed to using ExtendSim, ES10 has many new features and changes that will impact how you build models and use the application. This reference provides important information you should know before using ES10.

About this document

This document covers requirements, the new product lineup, typical upgrade paths, installation and activation, and specific information for converting your models and libraries to ES10.

It does not list all the new features in ES10. To see those, go to https://www.extendsim.com/products/features/new

Requirements

The following system requirements apply to Trial, Individual, Academic, Floating, Node-Locked, RunTime, and Student versions of ExtendSim 10. ASP and OEM license requirements are unique to their intended usage.

- **Computer**: Since simulation is processor-intensive, we recommend that your device have the fastest possible 64-bit processor (minimum 1GHz and it must be 64-bit). Note: ES10 is multi-threaded and takes advantage of multiple cores when running multiple models at the same time. However, when running a single model (even running it multiple times), it is more important to have cores with a faster processing speed than to simply have more cores.

- **Operating System**: A 64-bit version of Windows 10, 8.1, 7 (SP 1), Server 2016, Server 2012, or Server 2008 R2. (Mac OS version not yet released.) NOTE: for Windows OS prior to 8.1, text in dialogs may overlap if you use anything other than 100% for the display’s Scale and Layout.

- **Memory and Disk Space**: 2 GB RAM; 500 MB disk space

- **Browser**: A current version of Chrome, Explorer, Edge, Safari, or Firefox to download product updates.

- **Internet Access**: Required for automated product activation. (If your computer has no internet access or your system blocks ExtendSim from receiving encoded data from the internet, product activation can be accomplished manually.)

- For connecting to external applications using OLE/COM, DLL’s, and Shared Libraries:
  - If you use the Scenario Manager block to connect to JMP or Minitab, or use the Data Import Export block to exchange data with ODBC or ADO databases such as Access, those applications as well as the application drivers used to exchange data with the ExtendSim blocks must be 64-bit compatible. This also applies to any custom blocks you build that connect to external applications using an OLE/COM DLL.
  - Any DLL’s or Shared Libraries called by ES10 must be built for 64-bit execution.
Overview

Major changes to the product line in ES10

- Product lineup and versions
  - Full model developer versions for industry and academia: *ExtendSim CP, ExtendSim DE, ExtendSim Pro*
  - Limited versions: Trial, Analysis RunTime, Player RunTime, Student
  - Other: *ASP* (cloud-based self-hosted ExtendSim) and *OEM* (embed simulation power in your own applications)

- License types and maintenance
  - Individual, Node-Locked, or Floating license types
  - New license management system
  - Annual maintenance subscription

- Three new libraries (see page 9 for descriptions)
  - *Report* library (all products) includes the new Reports Manager block
  - *Chart* library (all products) replaces the Plotter library which will now be in Legacy status
  - *Reliability* library (ExtendSim Pro) integrates reliability block diagramming (RBD) with ExtendSim

Upgrade paths to ES 10

- To *ExtendSim CP 10*
  - For continuous process modeling
  - Typical upgrade path: from prior releases of *ExtendSim CP*

- To *ExtendSim DE 10*
  - For discrete event modeling
  - Also supports continuous process modeling
  - Typical upgrade path:
    - From *ExtendSim OR*
    - Or, as long as you don’t use the Rate module, from *ExtendSim AT*

- To *ExtendSim Pro 10*
  - Advanced technologies such as discrete rate modeling with the Rate library and LP Solver and reliability block diagramming (RBD) with the new Reliability library.
  - Also supports discrete event and continuous process modeling.
  - Typical upgrade path:
    - From *ExtendSim Suite*
    - Or, if you use the Rate module or want to use the Reliability module, from *ExtendSim AT*

⚠️ The 3D engine has not yet been converted to ES10. If you use 3D for your models, continue using your previous release (i.e. ExtendSim Suite 9) until the 3D engine is converted to 10 and available in ExtendSim Pro.

For a complete description of the ES10 product line, go to ExtendSim.com.
Before Upgrading to ExtendSim 10

Update your prior release to ExtendSim 9.2

- When you upgrade to ES10, your models and any custom blocks and libraries from prior releases (7-9) will need to be converted to the new ES10 format.
- We’ve done our best to make this process work well. However, it is strongly suggested that, if you haven’t already done so, update to ExtendSim 9.2 before using ExtendSim 10. Release 9.2 will provide the smoothest transition for your models and any custom blocks you’ve created. If you are using ExtendSim 9.0 or 9.1, the 9.2 updater is available as a free download at ExtendSim.com/Support/Updates.

ES 10 will open models and libraries created in releases 7-9. It does not support blocks or models created in releases prior to 7.

Make sure you have upgraded to the correct product

The product lineup has changed in ES10, so be sure you upgrade to the correct ES10 product given your prior usage and current modeling needs. For more information, see “Upgrade Paths to ES10” on the previous page or use the Product Advisor located at ExtendSim.com.

- The Discrete Rate module (the Rate library and LP solver) has been moved from ExtendSim AT 9 to ExtendSim Pro 10. If you used those components in prior releases, and want to continue using them, be sure to upgrade to ExtendSim Pro 10.

Release 10 is 64-bit application and requires that your device have a 64-bit OS. If your OS is not 64-bit, continue using release 9 until you obtain a 64-bit device.

- The 3D engine has not yet been converted to ES10. If you use 3D for your models, continue using your previous release (i.e. ExtendSim Suite 9) until the 3D engine is converted to 10 and available in ExtendSim Pro.

Before launching ES10

- ES 10 does not support blocks created prior to release 7 unless those blocks have been compiled in releases 7, 8, or 9.

  If you have created custom blocks (other than hierarchical blocks) in release 7, 8, or 9, read the instructions on page 12 BEFORE moving those libraries into the ES10 folders and before opening any model files in ES10.

- If you have saved a hierarchical block (HBlock) in a library, and the HBlock contains blocks from a release prior to 7, read the warning on page 7.

- If your models use Equation blocks, there have been some function changes:
  - DateToString, TimeToString, and CalcDate are no longer supported. See instead the EDDateToString and EDCalcDate functions in the Technical Reference.
  - There are new EColor functions that store the color information as a single integer, rather than using RGV or HSV. (Legacy functions that use and support the old color information are still working in ES10.)

- Due to architectural and file format changes, once model files have been saved in release 10 they cannot be read by older releases.

- If you keep a release 9 or prior license of ExtendSim installed on your computer:
  - If you typically launch ExtendSim by double-clicking a model or library file, and you have multiple instances of ExtendSim installed, the ExtendSim application that was last installed will open. To instead cause a different release of ExtendSim to open, use that release’s File > Update Launch Control command (Windows only). Depending on your privileges, you may need to right-click the ExtendSim application and select Run as Administrator before giving the command.
  - The icons for the model and library files will reflect whichever release of ExtendSim was installed last.
Technical support is limited to the most current release.

**Installing, Launching, and Activating ES10**

**Obtaining an ExtendSim 10 license**
- Individual licenses of ExtendSim 10 are available as downloads from the ExtendSim.com website and online store. These downloads include Model Developer Editions of ExtendSim CP, ExtendSim DE, and ExtendSim Pro as well as Individual licenses of the Analysis RunTime and Student versions of ExtendSim.
- Other ExtendSim license types (Floating, Node-Locked, ASP, etc.) can be ordered directly from Imagine That Inc. or from your local distributor or reseller.

**Installing ES10**
- Individual and Node-Locked licenses have an automated software installer.
- Floating licenses, including the ASP license, have an additional installer for the License Manager that regulates usage.

1. Instructions for installing and activating all license types are available at [https://www.extendsim.com/support/activate](https://www.extendsim.com/support/activate).

**Launching the downloaded software**
- If you have downloaded ExtendSim from our website, it operates as an Individual license that will run in Trial mode so you can use the software for free for up to 30 days.
- Each time you launch ExtendSim during the Trial period the Activation dialog appears with 3 options:
  - **Try.** You’ll have 30 days to access all the powerful simulation capabilities in ExtendSim. Until you purchase and activate ExtendSim, the Activation dialog will appear on startup and report the number of days remaining in your Trial period, plus there will be a "Trial Version" watermark stamped behind all your models. But all that goes away on activation.
  - **Purchase.** Selecting this will take you to the ExtendSim online store to purchase an Activation Key for the Individual license. If you don’t have an internet connection, ExtendSim will provide alternate methods for purchasing ExtendSim.
  - **Activate.** Make it official! Drop your Activation Key and other required information into the entry fields. Your ExtendSim license will automatically be activated and tied to the computer upon which the activation is performed...as long as you have an internet connection on that machine. If you don’t have internet access, ExtendSim will offer a manual option to activate your license.

1. There is no Trial period for Analysis RunTime or Student versions. Until activated, the only options they offer on launch are to purchase or enter an Activation Key.

**Activating an Individual license**
1. Detailed instructions can be found on our website at [https://www.extendsim.com/support/activate](https://www.extendsim.com/support/activate)
- Automatic activation (most common)
  - Requires an internet connection.
  - Is available 24/7 from anywhere in the world.
  - Activation occurs in seconds once you enter your Activation Key in the Activation Dialog
  - Once activated, ExtendSim displays your Activation Key and the expiration date of your Maintenance and Support Plan on your ExtendSim startup screen.
- Manual activation
  - Use this method if your device is not connected to the internet, your internet is down, or firewall or virus protection software is blocking the activation’s access.
  - If ExtendSim is unable to accomplish activation automatically, it will present messages such as “License Activation Problems” or “No Internet Connection”. In those cases, activation must be accomplished manually.
Follow these steps to manually activate ExtendSim:

- Use the "Save Activation Info as Text File" button on the error message to generate a text file (ExtendSim Activation Info.txt) that contains the activation information. You can save the text file anywhere you want; it is saved by default to the top level of your Documents folder.
- Using an email address that can receive an attached text file in return, email the text file to sales@ExtendSim.com.
- We will generate a text file named ExtendSim.lic and email it to you. (Note: Depending on the day and time we get the information, it may take up to 3 days for us to email you the ExtendSim.lic text file.)
- Place the ExtendSim.lic text file in your Documents/ExtendSim folder. (Place it at the same level as the ExtendSim.ini file, not inside the Documentation folder!)
- Restart ExtendSim and you’ll be activated!

Activations are tied to your customer account.

**Activating other licenses**

- Licenses other than the Individual license are activated using different methods than described above.
- See the ExtendSim.com website at https://www.extendsim.com/support/activate for installation instructions.

**Updating ExtendSim 10**

- Once you have activated ExtendSim, you should not need to reactivate unless your Maintenance and Support Plan has been renewed or you have purchased additional Event Cycles for the Reliability module of ExtendSim Pro.
- To update an Individual license of ExtendSim or to update Client licenses for a Floating license, download the Trial version from the ExtendSim.com website and install it over your existing ExtendSim installation.
- Do not use the Trial version of ExtendSim to update installations of ExtendSim ASP on the ASP Servers. There is a separate updater for the ASP product.

**Deactivating and uninstalling**

- To move an Individual license of ExtendSim from one device to another, you must deactivate ExtendSim on the first device (using the Help > Deactivate ExtendSim command) before activating it on the second.
- Be sure to deactivate your ExtendSim license if you are selling/giving away your computer.
After Launching ES10

1. Be sure you have read the instructions on page 3 before launching ES10 if you:
   - Have created custom blocks in ExtendSim
   - Saved hierarchical blocks in a library and the hierarchical block contains pre-release 7 blocks
   - Use date and/or color functions in Equation blocks

Things to notice when you first launch ES10

- ExtendSim 10 starts with a Getting Started model with two tabs:
  - The Getting Started tab has Quick Start Guides, Videos, tutorial models, example models, and much more.
  - The Upgrading to ES10 tab has links to all the new features and to an online flipbook of this document.

- Other obvious changes:
  - There is a new Tools menu and toolbars at the top and sides of the worksheet
  - Library windows now automatically open when libraries open.
  - Menu commands have been reorganized. In some instances, previous commands (such as those in the Text menu) have been replaced by toolbars.
  - The Navigator is now just for navigating through a model’s hierarchical layers. The Database List and Library Windows are separate commands and windows.

- Because the options have been revised and updated, you will need to restate any custom preferences. Do this in the Edit > Options menu.

- Depending on the product, you will see new Chart, Report, and Reliability libraries; see page 9.

Check out the new documentation and video tutorials

- Even if you are accustomed to using ExtendSim, release 10 has new features and changes that will impact how you build models and use the application.

- The User Reference and Technical Reference have been updated and reorganized for ES10. In addition, there are several new eBooks and video tutorials that ship with ExtendSim. See page 11 for details.

- To quickly get up to speed, we suggest you at least go through the first few chapters, and/or the corresponding video, of any relevant Quick Start Guide.

Opening models and hierarchical blocks built in prior releases

- If your models use libraries with custom blocks (other than hierarchical blocks), read the instructions on page 12 BEFORE moving those libraries into the ES10 folders and before opening any model files in ES10.

- If you have saved a hierarchical block (HBlock) in a library, and the HBlock contains blocks from a release prior to 7, see the warning on the next page.

- When models from prior releases are opened in ES10, they are copied and converted to a new format and “-ES10” is appended to their names.

- To maintain your existing (pre-10) models, either save the converted model with that modified name (ending in -ES10) or rename the converted model to the same name as the original and save it to a different location.

1. If your model opens with a blue rectangle replacing one or more graphic objects, it is because ES10 is unable to properly convert the graphic. The graphic could be an entire or partial block or hierarchical block’s icon or a picture on the model worksheet or notebook. In a few cases, versions prior to 10 saved pictures internally in a format that ES 10 cannot convert. The only way to fix this is to manually replace the graphic with a new one.
the original or a new graphic object. See the User Reference for a list of supported file formats.

1. It is best to convert all your models to ES10 at the same time and to use the same libraries. If that isn’t possible or practical, save copies of whichever libraries you used to convert models and “freeze” those copies without making changes. Then use the “frozen” libraries when you later convert prior-release models. Using libraries that are as close as possible to what was used to build the models will give the best conversion results.

2. If you have saved a hierarchical block (HBlock) in a library, and the HBlock contains blocks from a release prior to 7, and those blocks are not from the v6 Legacy libraries (Generic, Discrete Event, and Mfg):
   1. If those blocks have not been properly compiled in ExtendSim 7, 8, or 9, ES10 will not be able to properly convert them to the new format. Instead, it will give a warning message when you open that library or open a model that uses that HBlock.
   2. To fix the problem, do the following:
      - **In your prior release (7, 8, or 9)** and using your original (non-Legacy) library:
        - Open the library that gave the warning message
        - Open that library’s Library Window
        - Use the Library > Library Tools > Compile Open Library Windows command to compile the library
        - Drag each HBlock that got a warning message onto a blank model worksheet **in your prior release**
        - Open the HBlock’s structure and make some insignificant change so that the block needs to be saved
        - Close the structure window and choose Also Save to Library
      - Launch ES10
        - Open the fixed original library (.lfx, not .lbr) in ES10 to convert the library to the ES10 format.
        - If you’ve already converted that original library in ES10 (.lbr) you’ll get a warning message. Just click OK on that message to continue the conversion, replacing the previously converted library.
      - Repeat for each HBlock that has prior release blocks in it, and for each library that contains those HBlocks.

3. The above process DOES NOT convert blocks from the v6 Legacy libraries (Generic, Discrete Event, and Mfg)! ES 10 does not ship with the v6 Legacy libraries because it is not compatible those libraries and does not support them. See page 10 for more information about Legacy libraries.

---

**Verifying Models: Automating the Process**

ExtendSim 10 ships with an automated test environment so you can verify models between releases and between changes you make to your models. There are two components to the test environment. They are used differently depending on whether you want to test several models at a time or only one model:

- The Compare Results application located at Program Files/ExtendSim10 is for testing multiple models
- The Model Compare block (Utilities library) is useful for testing a single model

These tools help identify any differences in two situations:

- Verifying that models will generate the same results when there is a new release of ExtendSim. The test environment simplifies the process of comparing simulation results between two ExtendSim releases – looking for any differences between models that were saved in a previous release and the same models run in the new release.
- Determining if changes made to a model affect the results. In the same manner as verifying between releases, you can compare copies of the model saved before and after you’ve made changes.

For complete information on how to use these tools for model verification, see the section “Automated test environment” in the User Reference.
New Features to Note When Using ES10

Building models

- ES10 uses Point and Click, rather than Drag and Drop, almost everywhere. For example, to manually place a block on a worksheet, click on the block’s icon in the Library Window then click on the worksheet where you want the block to go. To place the same block multiple times, hold down the Alt key while clicking on the worksheet. See any Quick Start Guide tutorial for details.

- As an alternative to manually placing a block in the model, use the new Right-Click Connect feature to add blocks and connect them at the same time. See the first tutorial in any Quick Start Guide for an example.

- If you accidentally select a block or start a connection line, use the ESC key.

- In products other than ExtendSim CP, if the Item library is open an Executive will automatically be placed on new model worksheets. You can control that through the command Edit > Options > Model tab.

- CTRL+Y is now Redo and no longer opens the Simulation Setup command (which is CTRL+J).

- To copy data table headings along with the data, choose the command Edit > Copy Data with Headings or use the keyboard shortcut Ctrl+Shift+C. It is no longer an Option setting.

- To move a cloned frame and all its contents, frame-select everything with the Clone tool then click on the perimeter of the frame.

- Use the new Chart library (rather than the legacy Plotter library) when building new models.

1 Since ES10 used a different development architecture, you cannot copy objects (graphics, hierarchical blocks, etc.) from release 9 or earlier and paste them directly into ES10. Instead you must first convert the models, blocks, etc. to ES10.

Running models

- ES10 is a 64-bit application. Run speeds should be faster than previous releases but the Run Mode affects speed too.

- There are two new Run Modes accessed by toggling the Run Mode button in the Model toolbar:
  - Use the fastest mode to run a single model as fast as possible, even if you run it multiple times.
  - Use the multi-threaded mode to run multiple models at the same time, taking advantage of the ExtendSim multi-threading capability.

- The Run Simulation button becomes a Pause button while the simulation is running and a Resume button if paused.

- ES10 cannot open ".lrx" (runtime) library files. Instead, open the original (".lix") file in ES10, then use Library > Library Tools to generate a new file with the new ".lbrrt" extension.

2 Since ES10 is a 64-bit application, the external applications that ExtendSim exchanges data with, as well as the application drivers used to exchange that data, must be 64-bit compatible. This primarily applies to the Data Import Export block (Value library) and any custom blocks that connect to external applications using ODBC and ADO.

Creating blocks

- The Icon toolbar in the Tools menu has the Animation Object and the connectors used for creating hierarchical and custom blocks.

- The Dialog Items toolbar in the Tools menu has dialog items for creating block dialogs; this is a change from prior versions where you created dialog items using the New Dialog Item command.

- To access a dialog item’s properties, double-click the dialog item in the Dialog tab of a block’s structure window.

- See page 12 for other important notes if you create custom blocks.
New Chart, Report, and Reliability libraries

- **Chart**
  - The new Chart library replaces the Plotter library for all ExtendSim products.
  - So that you don’t have to change existing models, the Plotter library has been updated with new features.
  - The Plotter library has devolved to Legacy status and will no longer be supported. Unless you need to use the Plotter library’s Gantt, Histogram, Plotter Error Bars, or Plotter FFT, please use the blocks in the Chart library rather than the blocks in the Plotter library when building new models.

① To replace a Plotter block with a Chart block in an existing model, you must manually replace the block; you cannot use block substitution to replace a Plotter block with a Chart block.

- **Report**
  - The new Report library is available in all ExtendSim products.
  - The Reports Manager block is the primary interface in ExtendSim for creating reports from simulation runs for blocks, events, items, and resources. The block’s dialog provides filtering conditions to specify which blocks, events, items, and resources to generate reports for; data is stored in an internal ExtendSim database for ease of access and export.
  - Other blocks in this library are: Cost Stats, DB Statistics, Item Log Manager, and Statistics.
  - Some of the blocks in the Report library resided in other libraries prior to ES10. ExtendSim will automatically do the block substitution when you open any models that contain blocks that have been moved to the Report library.

- **Reliability**
  - The new Reliability module is only included with ExtendSim Pro and has its own eBook.
  - This module combines process simulation with reliability block diagramming (RBD).
  - Graphically and statistically describe when scheduled downs (maintenance and off-shifting) and unscheduled downs (failures) occur for individual resources and what impact that has on the availability of the entire system.
  - Use the Reliability library as a standalone RBD tool to determine how resource and component availability affect system performance.
  - Or, use Reliability with ExtendSim event-based capabilities to explore the impact of resource availability on key process metrics such as throughput, production costs, repair costs, utilization, inventory, service levels, and so forth.

*For the list of all the changes in ES10, see the ExtendSim.com website.*
Maintenance and Support

- An annual ExtendSim Maintenance and Support Plan (MSP) is required for all ExtendSim products except Trial, Analysis RunTime, Player RunTime, and Student.
- The cost of the MSP is included in the purchase price for the first year after purchase.
- As long as the MSP is kept current you can:
  - Get help with installation issues, basic usage questions, and troubleshooting.
  - Download free ExtendSim minor release updates.
  - Download free ExtendSim major release upgrades.
  - Move your ExtendSim license from one device to another (if allowed by the EULA).
  - Obtain replacement or updated Activation Keys.
  - Experience, evaluate, and influence future products and features.
- For the benefits to continue in subsequent years, the MSP must be renewed by the anniversary of the license activation.
- If the MSP lapses:
  - You will not get the MSP benefits (e.g. technical support, updates released subsequent to the expiration, replacement activation codes, etc.) listed above.
  - You will need to purchase upgrades at full price.
  - If the MSP is reinstated, it will restart at the original renewal date.
  - For more information, go to ExtendSim.com/products/purchase/plan.

Legacy libraries warning

- Legacy libraries are older libraries that are no longer supported, could result in problems in new releases, and at some point will not be included with ExtendSim.
- Legacy files are only supplied for a limited period of time so that you can:
  - Open older models and hierarchical blocks that use those libraries
  - Convert those models and hierarchical blocks to using the new libraries
- During its history, the following libraries have been relegated to Legacy status:
  - With the release of ES10, the Plotter library has been relegated to Legacy status. The new Chart library of ES10 replaces the Plotter library. **Please convert your existing models to using the new Chart library and avoid using the Plotter library when building new models.**
  - With the release of ExtendSim 7, the following v6 libraries were relegated to Legacy status:
    - Animation
    - BPR
    - Discrete Event
    - Generic
    - Mfg
    - Quick Blocks

⚠️ **AS OF ES10, THE V6 LIBRARIES ARE NO LONGER INCLUDED. ES10 IS NOT COMPATIBLE WITH AND DOES NOT SUPPORT THE v6 LEGACY LIBRARIES.**
Learning How to Use ExtendSim 10

eBooks
- Documentation has been rewritten and updated for ES10, and the previous User Guide and Developer Reference have been parsed into more concise documents based on modeling needs. When you upgrade to ES10, these eBooks get installed in the folder ExtendSim10/Documentation.
- Quick Start Guides (QSG’s)
  - The Continuous Process QSG, Discrete Event QSG, and Discrete Rate QSG contain tutorials and reference material to get new users quickly familiar with ExtendSim and knowledgeable about its features and benefits.
  - The guides are also helpful for existing users as they illustrate many of the new features of ES10.
  - Each has an accompanying video tutorial.
- Tutorial and Reference docs
  - Feature specific documentation that provides in-depth coverage of specific subjects.
  - Currently there are eBooks that explore the ExtendSim Database, Reliability, and Advanced Resource Management.
- User Reference
  - “How To” information for building, running, and using ExtendSim models.
  - Separate sections specific to discrete event and discrete rate modeling.
- Technical Reference
  - A resource for modelers who use equation-based blocks and for programmers who build or modify ExtendSim blocks and components.
  - Shows how to build a block, lists all the message handlers and functions, and much more.

Quickly access these documents by giving the command Help > ExtendSim Help.

Videos and example models
- In addition to the documentation, ES10 has new video tutorials and example models. For example, for hints about transitioning to ES10 see the short online video at https://vimeo.com/302142347.
- The documentation, models, and videos are easily accessed using the Getting Started interface that opens when you launch ExtendSim or by going to our website ExtendSim.com.
If You Have Created Custom Blocks

1. Before using ES10 to open a custom library or open any model that uses custom blocks created in releases prior to 10, note the following:

If your custom blocks have external source code

- First remove the external code using your current release (e.g. ExtendSim 9.2).
- Then COPY your custom libraries (with the external source code removed) into the ExtendSim10/Libraries folder.

If your blocks use includes you’ve developed from scratch

- Copy your custom includes into the ExtendSim10/Extensions/Includes folder.

If your blocks use the includes that shipped with ExtendSim 9.2.0 or earlier

- For includes that shipped with ExtendSim 9.2.0, you don’t have to change block code or include suffixes (e.g. change “Distributions v9.h” to “Distributions v10.h”) until you want to. In addition to the v10 includes, ES10 ships with the includes from 9.2.0; they are located in the ExtendSim10/Extensions/Includes/Legacy 9.2.0 folder.
- For includes shipped with ExtendSim releases prior to 9.2, rename copies of those includes, put those renamed includes into the ExtendSim10/Extensions/Includes/Legacy 9.2.0 folder, and change your block code to use those includes.

If your custom blocks use modified v9 includes that we sent to you after 9.2.0

- Those changes are already in the ES10 includes. You can either change your block code to use the v10 includes or copy the modified includes from ExtendSim 9.2 into the ExtendSim10/Extensions/Includes/Legacy 9.2.0 folder such that they replace the non-modified v9.2 includes.

BEFORE OPENING ANY MODELS, USE THE ES10 LIBRARY MENU TO OPEN CUSTOM LIBRARIES AND TEST THAT YOU’VE PROPERLY MADE THE ABOVE CHANGES!

Other Things to be Aware of for Custom Blocks

- The first time you open custom libraries in ES10 or open models that use custom blocks, the libraries will automatically convert to ES10, recompile, and get saved as copies with the extension “.lbr” (rather than “.lix”). That process also protects your prior-release libraries from being overwritten.
- Since libraries have a different extension in ES10, if you use the extension with the library name anywhere in your code you will need to change the extension. Common places where this could occur are in FileIsOpen, OpenExtendFile, PlaceBlock, and so forth.
- The new right-click-connect feature for adding and connecting blocks is database-based and can be adapted for your custom blocks. You can increase the number of common blocks, add your custom blocks, and so forth. Speak with an ExtendSim support person so your changes don’t get overwritten whenever ES10 is updated.
- If any of your blocks are based on an ExtendSim equation-based block:
  - Line break and line feed changes in ES10 require that you alter your code. For assistance, see the “12/21/2016” comment in the Equation v10.h include file.
- Since ES10 is a 64-bit application, the external applications that your custom blocks exchange data with, as well as the drivers used to exchange that data, must be 64-bit compatible. This primarily applies to external applications using ODBC and ADO.
- Regarding DLLs or Shared Libraries:
  - DLLs or Shared Libraries called by ExtendSim must be built for 64-bit execution. Either recompile your current 32-bit DLL as a 64-bit DLL or obtain a 64-bit version of the DLL from the vendor.
If your code calls a DLL or Shared Library that returns a pointer, you need to change the code to save the returned value to a Pointertype. See the Technical Reference for more information.

The procedure address returned by DLLmakeProcInstance and similar functions is NOT a 64-bit Pointertype variable. Instead, it is a 32-bit (4-byte) integer index that points to a pointer internal to ES10. This means the 32-bit block code used in previous releases is compatible with the 64-bit code of ES10.

DLLLongCFunction, DLLLongPascalFunction, and DLLLongStdCallFunction all call a DLL that returns a 64-bit integer that can be saved as either a ModL integer (32-bit) or, if needed, a Pointertype (64-bit integer/pointer).

Each animation object now has a Properties dialog that allows you to see the object’s zOrder, exactly positioning it within the layers of animation objects.

Use the Icon Positioner if model connection lines are misaligned:

When models that were built prior to ExtendSim 10 are converted to ExtendSim 10 the position of the model’s blocks could be slightly different, causing connection lines to be unaligned. In those cases, the Icon Positioner can be used to adjust the relative location of the icon within the Icon tab so that the connection lines to the block are correctly aligned. This adjustment has already been made in the current ExtendSim libraries, but you may want to use the positioner for any custom blocks that have been converted from earlier versions.

The Show icon positioner checkbox, located in the Icon tab of the block’s structure, hides and shows the icon positioner, the pink icon shown here. By default, the icon positioner is located at the upper leftmost position of the icon’s graphic items. The Reset Icon Positioner button resets the location of the icon positioner to the default.

To use the icon positioner, first determine approximately how many pixels and in what direction the icon needs to move so that the connection lines are aligned. Then in the Icon tab select the icon positioner and move it with the cursor or the keyboard arrow keys.

There is also a ModL function, blockAdjustPosition, that uses the location of the item positioner to shift the location of the block by the offset of the positioner location.

DateToString, TimeToString, and CalcDate are no longer supported. See instead the EDDateToString and EDCalcDate functions in the Technical Reference.

There are new EColor functions that store the color information as a single integer, rather than using RGV or HSV. (Legacy functions that use and support the old color information are still working in ES10.)

As of release 10 ExtendSim no longer supports Dynamic Data Exchange (DDE). It is an outmoded approach that’s incompatible with many IT setups, is no longer recommended for use, and is not really being supported by Microsoft. Use instead any of the other IPC capabilities ExtendSim supports, such as OLE.